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1 Getting Started
1.1 What is ButterflyNetRender™?
ButterflyNetRender (BNR) is a Network Rendering controller for 3D
Rendering application including:

LightWave 3D, Maya, Modo, Messiah Studio, 3DS Max, XSI, C4D, After
Effects, Digital Fusion, and more!

It also supports a Custom render Types (Custom Batch Commands); where
you can add support for almost any command line application.
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1.2 BNR applications:
ButterflyNetRender™ has 2 primary applications; The BNR Controller and
the BNR Client.

The BNR Controller manages and distributes the render queue.

The BNR Client renders scenes as instructed by the controller.

1.3 BNR Terminology:
• BNR Controller - The Application that controls all the clients on

the network.

• BNR Client - The application that talks to the controller and launch’s
RenderNode(s).

• RenderNode - The application that Renders the Image.

• Render farm - a collection of RenderNodes

IP address for the controller is in >options>controller information.

1.4 Features
The BNR controller can run in 2 modes - single user or multi user. When
running in multi user mode - the viewer can be accessed from a web browser.
The BNR Controller will be running a core network rendering engine and a
web service that is used for the user interface.

1.4.1 Single user mode

Single user mode will not require a login to access the main screen.

1.4.2 Multi User mode

Multi user mode will require a login for each user. The admin user will have
access to adding new users and configuring the software. (default user/pass:
admin/admin)
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2 Installation
2.1 System Requirements:

• Operating System: Windows XP, 2003, 2008, 2008r2, 2013, Win-
dows 7, Windows 8, Windows 10

• Clients: OSX 10.4 or higher, Linux RedHat, CentOS

• CPU: 1gigahertz (GHz) 32bit processor or 1GHz 64bit processor

• Storage: 80 (MB) hard disk (controller) 25 (MB) hard drive (client)

• A shared network directory that the Controller and Clients can access.

• Support rendering software like Lightwave, Messiah, Maya, Modo, C4D,
etc...

• Static IP address/Name for the Controller that the Client machines
can locate (ping). (The client can also be configured using DHCP)

NOTE:Windows® XP/7/8/10 supports 10 connects per shared
path, so if you want to have more then 10 nodes share a directory,
you will need to use a different file server Like: Linux with Samba
(Red Hat), OSX or Windows Server.

Windows® XP Home Edition is a consumer operating system
which only supports 5 peer to peer networking computers and it
does NOT support advanced networking such as domain authen-
tication.
You MUST install the Controller application "ButterflyNet" first
and configure it. Then install the Client applications "ButterFly-
Node". The Clients need to know which IP Address the Controller
is using to configure them.

2.2 Installing the BNR Controller:
BNR must be installed in the correct sequence in order for it to function as
expected. The BNR Controller MUST be installed and configured BEFORE
any BNR Clients are installed.
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2.2.1 with Lightwave

The configuration process will require access to the LightWave Programs and
plugin directories. For best results - Install Lightwave on the same machine
as the BNR Controller. Launch and run Layout and ’Clear’ and ’Rescan’
the Lightwave plugins (select the local Lightwave folder) and this will create
the Configuration files required for BNR. You will then need to use the BNR
Setup wizard for Lightwave.

2.2.2 with Messiah

To support reading of Messiah scenes you will need to install Messiah sutdio
on the BNR Controller machine. You will need to use the BNR setup wizard
for Messiah.

2.2.3 with Modo

The configuration process will require access to Modo programs and directo-
ries. Install Modo on the BNR Controller machine. BNR has a setup wizard
for Modo that will be used to create all the shared folder and files required
for rendering with Modo.

2.2.4 with Maya, 3dsmax, C4D, XSI, other 3d applications

Depending on the application you will usually need to install this on the BNR
Controller and BNR Client machines in the same location on each. This will
then give the ability to run a ’test’ from the BNR Controller to confirm all
is working.

2.3 Launch ButterflyNetRender
Install ButterflyNetRender setup application (One installer is used for the
32/64 version of windows).

Now launch the ButterflyNetRender start application (BNRStart) this is
used to start/stop the BNR module that will be running in the background.
The windows version includes a ’Brower’ application that will be used to
display the User Interface on the BNR Controller machine.
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2.4 BNRStart Application: (windows version)

You can use the ’Wizard’ under the Advanced tab to display all
the required settings or set them manually.
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2.5 BNRStart Config tab
BNRStart Config tab is used to configure which network card is used to serve
the web server and network rendering process. The defaults setting should
be fine in most cases.
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2.6 BNRStart Paths tab
This section is used to setup where the ’Shared Network folder’ is located for
use with all the ’local’ rendernode machines. All machines will need to be
able to see the path. If drive mapping is used - make sure all the machines
are using the same drive mapping letters. If mixing a Windows,OSX, Linux
envirnment - you will need to make sure the path is also available to the OSX
and Linux machines.
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2.7 BNRStart Advanced Tab
This is the advanced section. Don’t change the ’Launch this app’ or ’Prefer-
ences stored here’ as the defaults will always be correct.

• ’Reset to Defaults’ - will retore the original settings and then you can setup again.

• ’Setup Wizard’ - Step by Step to setup the configuration

• ’ProgramData folder’ - this will open the link where you can find the cfg files

• ’Webuser Mode’ - when this enabled - the system with run in Multi user mode

• ’Debug log’ - enable extra debug output information in the logs

• ’Log folder’ - this will show where all the output netrender*.log files are located
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2.8 Register ButterflyNetRender
Register ButterflyNetRender under the Options->Help->Register BNR.

Select the ’information’ tab, highlight the ’Application ID’ using the
mouse and ’copy’ to the buffer. Now you can press the ’Online Registra-
tion’ button to launch a browser into the BNR Membersite - where you can
login and request the registration code by ’pasting’ the Applicaiton ID into
the form.

You should receive a email with all the registgration information. Select
the ’register’ tab to enter the registration code. Press ’Validate’ to confirm
all is correct. Now ’OK’ and exit the BNR Controller to confirm all the
settings will be saved.
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2.9 Installing the BNR Client (windows):
To install the client, select your render machine and run the nodesetup exe.
The BNR Client can be installed on any computer on the network. The
LightWave software does not have to be installed on this machine. (The
Client will run the lwsn.exe from the shared network directory) Simply follow
the prompts in the installer. You only need one client on a machine as the
client can host multiple RenderNodes. When the client is run for the first
time it will need to be configured.

To configure the client, launch The BNR Client (if not already running)
and right click the butterfly icon that appears in the system tray (windows
OS). Select the configure option from the pop-up list.

Set the IP address to that of the BNR Controller and the number of
Nodes the client is to run. The advanced tab is where you can set the client
to run as a service or limit the availability of the client for rendering. The
IP address of the controller can be found by selecting >options>controller
information in the BNR Controller.

Render Nodes should be set to the number of render processes you wish
the machine to support, normally a number equal to or less than the number
of CPU’s on the host.

2.10 Installing the BNR Client (OSX):
Use the BNROSXClient.dmg to copy the BNR Client for OSX into the ap-
plications folder. You will need to configure the ’Paths’ and applications
setttings. Note: don’t use any spaces in the Client name - has this may
cause issues.
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3 BNR Start
3.1 Start app
Once you have the system configured - You will use the ’Start’ button on
the BNRStart application to launch the background module. The windows
version uses a ’Browser’ application to display the user interface - where the
OSX/Linux versions will launch link to the http network address that will
service the BNR user interface. (The http address button shows the correct
location)

12



3.2 Stop app
The Windows ’Browser’ once closed will stop the background module. Un-
der OSX and Linux the ’Stop’ button will be used to close the background
module.
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4 BNR Controller - Web User inteface
The browser interface will be used the configure and control BNR.

4.1 Login prompt
If running in multi user mode - a login prompt will be the entry point (default
username:admin

password:admin)
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4.2 Welcome
This tab will display useful information on where to configure and setup
BNR5.
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4.3 Dashboard
This will display quick information on what is happening in the render queue.
The left side menu will be used to setup or view some of the options in BNR5.

The ’Scenes’ and ’Status’ sections will display quick totals for Number of
Scenes and Rendernodes as well has the last errors.

The ’Frame Rendering graph’ will display the number of frames rendern-
odes have completed in the last 7 days.
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4.4 Queue
Display the render queue and all the jobs. use this section to ’add’ new jobs
into the queue.

Select render type and browse to where the file is located. Use the Right
click menu to ’start,stop’ the job.
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4.5 Nodes
Display the render nodes that will be used by the system

Rendernode menu
To access the Rendernode menu - right click on the scene.
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4.6 Frames
Display the frames created by Job. Select which Job you would like to see
and press ’Show’
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4.7 Trace Logs
Display the ’trace logs’ by Job. Select which file and the output will be
displayed in the lower panel.
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4.8 Menu section
Under the ’Welcome’ tab - Left side

This will be used to access the most common settings for BNR5.

4.8.1 File->Update Clients

Update the Clients to current version. Use this when updating the BNR
Controller.

4.8.2 File->Restart

Restart the Controller

4.8.3 Options->Controller Info

Display Controller Information.

4.8.4 Options->Preferences

BNR5 preference settings (see next section)

4.8.5 View->Select Columns

Enable/Disable which columns to display for the grids.

4.8.6 Help->Wiki

Link to Wiki information

4.8.7 Help->Register BNR

Use this to get the BNR Application ID and also register BNR.

4.8.8 Help->Check Updates

Check the internet for BNR updates

4.8.9 Help->About

Display the BNR About form
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4.9 Preferences
Under the ’Welcome’ tab - select the ’File->Options->Preferences’ section.

Configure the preference settings for BNR.
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4.10 Users (Admin section)
This will be used to Create, and edit user settings (for multi user mode).
(This section will only be displayed if the user has admin rights)
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4.11 Configuration (Admin section)
This will be used to configure BNR5. The section will only be available to
admin users.

(This should be used to setup BNR before jobs are started._

4.12 Configure - Lightwave - (Wizard)
Under the ’Configure’ tab - select the ’Platform Setup Wizard’ section.

Use the wizard to setup the Lightwave rendertype
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Lightwave setup

Setup all the settings required to ’Run the Lightwave Wizard’
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The wizard will step by step all the required steps to setup the Platforms
for network rendering.
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4.13 Import BNR4.5 settings
Under the ’Configure’ tab - select the ’Import settings from BNR4’ section.

If you are upgrading from BNR 4.5 - you can import your current ’Render
Types’ to get BNR5 up and running quickly.

This will run a import process that looks for the bcontrol4.cfg file and
reads all the settings. This will also read all the rendertype settings. (You
must have BNR4.x installed on the machine)
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4.14 Setup Platforms
Under the ’Configure’ tab - select the ’Platform settings (render types)’ sec-
tion.

Configure and setup all the render types that will be used. You will need
to make sure you ’Enable’ the platform - otherwise you will not be able to
’Add’ that job type to the Job queue.

For example to setup Lightwave - select the Lightwave render type and
change the settings (NOTE: - if you are using the setup wizard - you should
not need to change these settings)
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4.15 Notifications
Under the ’Configure’ tab - select the ’Notification’ section.

Setup the email server settings to enable the ability to notify of render
reports, status and progress during rendering. Use the ’Test Email’ to confirm
the email settings are configured correctly.

Use the ’Email SMS’ tab to setup the ’sms email address’ that will send
SMS messages to your phone.
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4.16 Shared Paths
Under the ’Configure’ tab - select the ’Shared Paths’ section.

4.16.1 Shared Paths

(windows) Configure the Linux/OSX shared paths that will be used to match
up to the windows path. NOTE: The main windows shard root path will be
setup in the ’BNR Startup’ application.
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Browse Content

Setup the paths that can be used to browse for jobs and assets. (this can be
used to limit the locates where files can be located)
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4.17 Advanced Settings
Under the ’Configure’ tab - select the ’Advanced settings’ section.

4.17.1 Groups and Collections:

Configure and setup the render Groups and Collections. These will be used
to define different rendering parts of the farm.

Select the ’groups’ tab to Enable and Name the Groups. (The group must
be enabled before it will be available for selection in the job properties)
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Collections tab:

In the ’Collections’ tab - Enable and name the Collection
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Setup Collections tab:

In the Setup tab - Configure the Collection settings. Define what groups
will be included in the collection. Rendernodes can also be selected in the
collection.
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4.17.2 Priority settings:

Configure and setup the priority groups for the farm. This can be used to
limit different types of jobs.
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4.17.3 Remote access:

Configure and setup the remote access to the Controller and autoload settings
(for adding scene via the BNR Submit or autoload shared network folder)
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5 Building Render Farm
This is a little beyond the remit of a document such as this. However there
follows an overview of the major components involved.

A render farm is a collection of machines that are used for rendering. In
many places Animation workstations are considered acceptable additions to
a farm.

The main components to consider in a farm are the render boxes, a file
server and the connection between the server and the render boxes. The
more boxes you put on the farm. The better the connection between them
and the server needs to be otherwise a scene loading bottleneck will manifest
when the render machines try to load the scene files.

The final component that a farm needs is a controller. In this instance
the controller is BNR and under normal circumstances It would live on the
server, out of the way. But there is no reason why it couldn’t live on one of
the workstations instead.
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5.1 SetupWindows Networking with TCP/IP Addresses
(Windows)

For full details on TCP/IP Networking, see your windows help files. TCP/IP
stands for Transmission Control Protocol/Internet Protocol. It is the default
wide area network protocol that provides communication across diverse in-
terconnected networks.

In order to use TCP/IP your computers are going to need network cards
and connections to each other. Assuming you have a viable network situation
hardware wise the next thing to do is set up the TCP/IP.

In order to do this you will need to get the properties of your network
card, which can be found in the windows control panel. Once open click the
install button and select the Protocol component TCP/IP to install. OK the
selections till you are back to the properties of your network card. (if the
TCP/IP protocol is missing)

Double click the TCP/IP protocol. You should see a window like the one
below.:
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In order for your machines to be able to talk to each other they need a
unique network address, the IP address. The IP address is like a telephone
number.

When a computer wants to talk to another computer it dials the relevant
IP address and leaves its IP number so that the contacted computer knows
which machine is trying to contact it and where to send any requested data.
The IP numbers come in 4 blocks the first three of which must be identical
on all machines.

The last block would carry the unique number. In the example above this
machine is number 7 of the 192.192.200 network. There is a specific set of
IP addresses that are reserved for LAN’s so as not to conflict with Internet
exposed IP addresses of fixed domains. Check your windows documentation
for further details.

If you are running a domain server too you will have to set the default
gateway that the computer will use. The default gateway is the IP address
of the domain controller. In the example above the domain controller is
machine 1 on the 192.192.200 network. Unless your network is massive you
will not need the sub set mask, if your network is that large you should be
getting your TCP/IP information from somewhere else!
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5.2 Setup a Shared Network Directory (windows)
The final part of your network is the network directory. A network directory
is just like any other directory on your computer. The only difference is that
it is unlikely to physically be on your computer. It is more likely to be on
another networked machine. Network directories are used for holding project
data in a place that is easy for multiple user’s to get at and work on.

The Lightwave content folder is an excellent example of a folder that
would benefit from being a shared directory.

(NOTE: Your version of Windows setup might look different - please
check your help files)

In order to make a shared directory firstly find/create a folder that you
want to share and right click it and select the Sharing option. The following
window will open up. Click the Share this folder button and name your
folder, allow the maximum users.
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The file has now been exposed to the network but (if you have a domain
controller) no one is able to use it yet because they will need permission to
access the folder. Select permissions and the following window will open.

Enable other users to create and destroy files in the folder. (see above)

For more information on network security and permissions check
with your network supervisor or the windows help files. Any fur-
ther information is beyond the scope of this document.
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6 Quick Start
6.1 Quick Start - Add Scene and Start Rendering
Launch the BNR Controller and launch some BNR Clients. Select the add
scene button from the BNR Controller and load in some scenes
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After selecting the Scene - the Controller will process the data:
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Now the job will be displayed in the queue. Right click on the row to
access the menu to ’start’ the rendering.
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6.2 Start Job
To start the job - right click on the row to access the menu to ’start’ the
rendering or select the ’Start’ button with that row selected.
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You will be prompted if you want to skip already processed frames. (Don’t
re-render frames already created)

If you have any issues with the scene settings, ie: missing output path
or prefix name - you will be prompted to correct that issue - otherwise the
job will start rendering on the nodes that have been setup for this group and
priority.
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6.3 Modify Scene settings
You can modify the Scene settings by selecting the ’properties’ menu option:

6.3.1 Select the ’Output’ tab to modify output settings:
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6.3.2 Select the Camera tab to modify Camera rendering size
settings:

49



6.3.3 Select the Advanced tab to modify Groups and Priority set-
tings:
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6.4 Setup Pre and Post lua scripting
Pre and Post processing scripts can be setup in the ’Pre/Post’ tab in the
Scene Properties
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7 Modify User interface
7.1 User Interface
BNR5 is developed using the standard HTML and CSS. You can customize
the user interface by adding your settings to these css files (Please don’t
modify other css files as they could change with future updates)

Info dialog boxes:

\ui\user\liquified_ui.infodialog.custom.css

Main interface:

\ui\user\liquified_ui.main.custom.css

Property Dialog boxes:

\ui\user\liquified_ui.propdialog.custom.css
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TRADEMARKS

ButterflyNetRender is a trademark of Liquid Dream Solutions. Brand names
and product names are trademarks or registered trademarks of their respec-
tive companies.

LIMITED WARRANTY ON SOFTWARE

LIQUID DREAM SOLUTIONS DISCLAIMS ALL IMPLIEDWARRANTIES
ON THE PRODUCT, INCLUDINGWITHOUT LIMITATIONWARRANTIES
OFMERCHANTABILITY, PERFORMANCE, AND FITNESS FOR A PAR-
TICULAR PURPOSE. LIQUID DREAM SOLUTIONS WILL NOT BE LI-
ABLE FOR ANY BUG, ERROR, OMISSION, DEFECT, DEFICIENCY,
OR NONCONFORMITY IN ANY SOFTWARE. AS A RESULT, THE SOFT-
WARE IS SOLD “AS IS,” AND THE PURCHASER ASSUMES THE EN-
TIRE RISK AS TO ITS QUALITY AND PERFORMANCE.

LIQUID DREAM SOLUTIONS SHALL IN NO EVENT BE LIABLE
FORDIRECT, INDIRECT, SPECIAL, INCIDENTAL, CONTINGENT, OR
CONSEQUENTIAL DAMAGES RESULTING FROM ANY DEFECT IN
THE SOFTWARE OR ITS DOCUMENTATION INCLUDING DAMAGES
FROM LOSS OF DATA, EVEN IF LIQUID DREAM SOLUTIONS OR
AN AUTHORIZED LIQUID DREAM SOLUTIONS DEALER HAS BEEN
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. YOU AGREE
THAT LIQUID DREAM SOLUTIONS LIABILITY ARISING OUT OF
CONTRACT, NEGLIGENCE, STRICT LIABILITY IN TORT, OR WAR-
RANTY SHALL NOT EXCEED ANY AMOUNTS PAID BY YOU FOR
THIS PRODUCT. Any written or oral information or advice given by LIQ-
UID DREAM SOLUTIONS dealers, distributors, agents, or employees will
in no way increase the scope of this warranty, nor may you rely on such oral
or written communication. Some provinces/states do not allow the exclusion
or limitation of implied warranties or liability for incidental or consequential
damages, so the above limitation or exclusion may not apply to you. This
warranty gives you specific legal rights, and you may also have other rights
which vary from province/state to province/state. The laws of Washington
shall govern this Agreement.
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